DIDWW - Inbound Voice with [Venezuela] – Incident details
Outbound Voice experiencing degraded performance
Inbound Voice with [Venezuela]
Resolved
Degraded performance
Started 11 days agoSeptember 11, 2026Lasted 3 minutesSeptember 11, 20261:131:16 PMUTC
Affected
Inbound Voice
Degraded performance from 1:13 PM to 1:16 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
A fix has been applied for the Inbound Voice issue affecting [Veneuzela] DIDs. Call completion is recovering, and we are monitoring to confirm full service restoration.
Investigating
UTC
Investigating
UTC
We are currently investigating an issue affecting Inbound Voice service for [Venezuela] DIDs. Customers may experience connectivity issues, failed connections, or unavailable inbound calls towards affected numbers.