DIDWW - Inbound Voice with [Mexico] – Incident details
Outbound Voice experiencing degraded performance
Inbound Voice with [Mexico]
Resolved
Degraded performance
Started 1 day agoSeptember 21, 2026Lasted 3 minutesSeptember 21, 20262:072:10 PMUTC
Affected
Inbound Voice
Degraded performance from 2:07 PM to 2:10 PM
Updates
Resolved
UTC
Resolved
UTC
The issue affecting Inbound Voice service for [Mexico] DIDs has been resolved. Service is operating normally.
Monitoring
UTC
Monitoring
UTC
A fix has been applied for the Inbound Voice issue affecting [Taiwan] DIDs. Call completion is recovering, and we are monitoring to confirm full service restoration.
Investigating
UTC
Investigating
UTC
A fix has been applied for the Inbound Voice issue affecting [Mexico] DIDs. Call completion is recovering, and we are monitoring to confirm full service restoration.