DIDWW - Local calls to Estonia destinations are failing with SIP 503 Service Unavailable – Incident details
Support
Get updates
Email
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Support
Get updates
Outbound Voice experiencing degraded performance
Local calls to Estonia destinations are failing with SIP 503 Service Unavailable
Resolved
Partial outage
Started about 1 month ago
August 12, 2026
Lasted about 1 hour
August 12, 2026
10:54 AM
12:04 PM
UTC
Updates
Resolved
August 12, 2026 at 12:04 PM
UTC
Resolved
August 12, 2026 at 12:04 PM
UTC
This incident has been resolved.Calls are now working properly
Identified
August 12, 2026 at 10:54 AM
UTC
Identified
August 12, 2026 at 10:54 AM
UTC
We are continuing to work on a fix for this incident.
UTC
UTC
UTC
UTC
UTC