DIDWW - Inbound Voice with Zimbabwe – Incident details

Outbound Voice experiencing degraded performance

Inbound Voice with Zimbabwe

Resolved
Degraded performance
Started 1 day agoLasted 6 minutes

Affected

Inbound Voice

Degraded performance from 12:12 PM to 12:16 PM, Operational from 12:16 PM to 12:18 PM

Updates
  • Resolved
    UTC
    Resolved

    The issue affecting Inbound Voice service for Zimbabwe DIDs has been resolved. Service is operating normally.

  • Monitoring
    UTC
    Monitoring

    A fix has been applied for the Inbound Voice issue affecting Zimbabwe DIDs. Call completion is recovering, and we are monitoring to confirm full service restoration.

  • Identified
    UTC
    Identified

    We have identified the issue affecting Inbound Voice service for Zimbabwe DIDs as related to an upstream interconnection. We are working to restore regular call completion.